Squid on Novell SUSE Linux

Pre-Built Binary Packages

  • /!\ Seeking information:

    • what exactly are the available versions on SLES? both official and semi-official

Maintainer: unknown


Bug Reporting: https://bugzilla.novell.com/buglist.cgi?quicksearch=squid

Install Procedure:


  • /!\ There is just one known problem. The Linux system layout differs markedly from the Squid defaults. The following ./configure options are needed to install Squid into the Linux structure properly:


LDAP support fails to build

Seen on Squid-3.1 and older. The build appears to start well then breaks with strange compile errors on the LDAP helpers. Usually mentioning missing variable definitions or miss-placed ) brackets.

You just have to install the openldap2-devel package from the SLES11-SP1-SDK-DVD:

zypper install openldap2-devel

Squid-3.2 does much better support detection and should present you with a useful message about LDAP support files not being found.


CategoryKnowledgeBase SquidFaq/BinaryPackages

KnowledgeBase/SLES (last edited 2011-05-10 11:55:42 by Amos Jeffries)